
Introduction to CadSoft Eagle 

Cadsoft Eagle is printed circuit board (PCB) computer aided design (CAD) software.  The 

software allows users to create schematic circuits, PCBs, and libraries, while also allowing user 

to generate bill of materials (BOM) and Gerber files.  The software is free, easy to use/learn, and 

is compatible with Windows, Linux, and Mac OS.  The free version can be downloaded from 

http://www.cadsoftusa.com/download-eagle/ 

 

These tutorials will cover basic navigation of the software‟s environment, creating libraries and 

basic components, creating schematics and PCBs, and generating necessary files for fabrication. 

 

1.1 Accessing the Main Control Panel 

 

Each time Eagle is opened, a Control Panel screen will appear.  All projects, libraries, processing 

jobs, and files can be accessed, created, and edited from this screen.  

 

 
Figure 1. Control Panel 

  

http://www.cadsoftusa.com/download-eagle/


1.2 Starting a New Project 

 

Each time a user wants to create a new PCB, a project folder is used to store all necessary files 

such as the schematic, layout, and Gerber files.  To create a new project, first open the projects 

folder and click on Projects > Eagle. 

 

 
Figure 2. Control Panel – Eagle folder 

 

With the eagle folder opened as shown above in figure 2, click on File>New>Project to create a 

new folder to store all necessary files for a project. 

 

1.3 Creating a New Library 

 

Libraries are folders in the software that contain the files for individual components such as 

resistors, capacitors, integrated circuits (ICs), etc.  The user can create new parts by creating the 

necessary parameters for a component, storing them in a library, and accessing them in the 

schematic/layout portion.  To create a new library, click on File>New>Library. A pop-up 

window will appear.  To create a part like a resistor, there are three components that need to be 

designed: Symbol, Package, and Device.   

 

The Symbol represents the schematic form of the component.  This component is used in the 

schematic editor which allows the user to connect wires from component to component. When 

observing datasheets, a user will see a symbolic representation of a component with labels of 

what each pin does.  That is the same case in Eagle.   

 

The Package is the physical representation of the component.  This component is used in the 

layout editor where the user places the part on a printed circuit board to wire.  Datasheets provide 

design specifications of the part, such as pin length and width and various distances.  Typically 

the design specifications can be found at the bottom of datasheets.  

 

The Device is the final step in creating a part.  In the device portion, pins are matched between 

Symbol and Package such that whatever way the user creates the Symbol, it correlates to the 

correct pin in the Package. 

 

The order in which the component is made does not matter, but the Device will always come 

last.  The user can either make the Symbol first and Device second, vice versa.  



All three components can be accessed/created from the pop up window. 

 

 
             Symbol 

       Package 

             Device 

 

Figure 3. Device, Package, and Symbol Creation 

 

1.4 Creating a Components Symbol 

 

When making a Symbol, a pop-up window will appear requiring the user to label the symbol.  

When using the schematic layout editor, this label will appear next to the component.  An 

example for naming a symbol is making a certain resistor size (package size).  Resistors come in 

various sizes such as 0402, 0603, 0804, etc.  If the user is making a 0603 resistor, a potential 

name is R0603. 
 

 
 

Figure 4. Creating a New Symbol 

 

After naming the Symbol, a Symbol Editor will appear. There are various tools that can be used 

to create the Symbol, but the most critical are the Name, Text, Rectangle, and Pin tools.   

 

 
 

Figure 5. Symbol Editor 



The first step adds the necessary number of pins onto the editor.  These pins are the symbolic 

representation of the pins of the component.  Arrange the pins such that there is no overlap with 

the labels.  Once the pins are laid out, use the Rectangle tool to draw a box for the pins.  This is 

helpful for documentation purposes.  The Name tool can be used to name pins and is helpful for 

documentation, and for Device creation.  An example of a symbol is shown in Figure 6. 

 

 
 

Figure 6. Symbol Example 

 

A general rule of thumb when creating Symbols is to add a name and value to the component.  

These labels are used to document the specific component and its value (capacitor, resistors, and 

inductors).  The software uses the “>” symbol as a reference to the Name and Value tools in the 

toolbar.  To add a Name and Value, use the Text tool in the toolbar and type “>Name” or 

“Value”.   

 

1.5 Package Creation 

 

Now select Package symbol in the main window.  Again, a name editor will appear asking for a 

Package name.  Components come in all shapes and sizes, but there are general package types 

available.   

 

The process of creating a Package varies from that of the Symbol.  In the symbol portion, the 

size and units do not affect the use of the component.  In the Package creation step, the 

component being made must match the design specification of the datasheet.  The first step in 

creating a components Package is identifying the type of unit used.  Depending on the country of 

origin, different units are provided by the manufacturer (typically millimeters or inches).  To 

change the units, the user can access the Grid editor on the top left.  The Size is the most 

important parameter because it affects the scaling of the grid of the Package editor.  The Multiple 

and Alt parameters will scale with the grids units.  

 

 
 

Figure 7. Grid Editor 

 



Similar to the Symbol creation, the most important tools that are used are the Name, Info, Wire, 

Text, Rectangle, and Pad tools.   

 

The Info tool provides necessary information on anything on the screen such as a wire, a pad, or 

a text.  Parameters can be set from editing the Info window.  For example, the user wants to draw 

a box that is 2x5 mm.  The user could draw an arbitrary box using the Rectangle tool, and then 

edit the dimensions of the box using the Info tool to meet the 2x5mm criteria.   

 

 
 

Figure 8. Package Toolbox 

 

There are two types of Pads that are used in the Package creation.  Pads represent the contact 

points for which components, such as resistors and capacitors, connect to the PCB layer.  The 

two types of Pads are either thru hole or surface mount device (SMD).  Use the name tool to 

label the pad so that it matches the datasheet.  

 

To create a Package, first place down the necessary number of Pads for the component.  Use the 

Info tool to edit the dimension of the Pad, such that the Pad properly fits the specification of the 

datasheet.  Then use the Info tool to adjust the coordinates* of Pad to its designated location. 

*Eagle references a component by the center of part.  For example, there is a circular part 

centered at (0,0) with a radius of 2mm. Eagle will refer to its location at (0,0), and therefore if 

the part is moved it will correlate to the position where the part was previously. 

 

After placing the Pads onto the editor, use the Wire tool to draw the dimension of the 

component.  Switch to layer 21 tPlace, which is specifically used for documentation.  Then, add 

the >Name and >Value labels. 

 

 
 

Figure 9. Package Example 
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1.6 Device Creation 

 

The last step is to connect the pins of the Symbol and Package.  Click on the Device symbol and 

a screen will prompt the user for a name of the device.  Typically, users name the Device and 

Symbol the same. 

 

 
 

Figure 9. Device Editor 

 

First, add the device by clicking on the Add tool located underneath the Wrench tool.  Select the 

component and center it to the crosshair in the editor. In the bottom right of the screen, click 

New > Connect.  In the new window, match the corresponding pin and pad and connect them.  

After connecting the pin and pad, save the components. 

 

1.7 Schematic Design 

 

A schematic is the file where the symbol of a device is connected with other parts to create a 

circuit.  Click on File>New>Schematic to create a new schematic.  

 

The general guide to building a schematic is broken into two processes: adding parts and wiring 

them.  Click on Edit>Add to add a new part to the schematic.  A window will appear that lists 

all of the libraries provided by the distributor and the libraries designed by the user.  There is a 

search bar to look for specific components or libraries. 

 

The most necessary components that need to be included in any circuit are the power and ground 

components.  To search for power and ground, type in “VCC” for power and “GND” for ground.   



 
 

Figure 10. Adding Parts 

 

With the parts placed, use the Wire tool to connect them.  The wire tool will draw a green line 

from where the user designates, and it represents a physical wire that would connect pins on a 

circuit board.   

 

Use the Name and Value tools to change the name of components or to add values.  When the 

user clicks on a component such as a capacitor with one of the tools selected, a pop-up box will 

appear.   

 

 
 

Figure 10. Changing Name and Value 

 

An alternative to connecting components is to use the Label tool.  By using the label tool, users 

can reference where a pin of a component should connect to.  The label tool is efficient in 

reducing the amount of space used by wires, and can help clean up the schematic from being 

overrun by wires.  Use the Name tool after placing a Label to link it to another existing Label.  

 

 
 

Figure 11. Adding a Label 

 



1.8 Creating a PCB 

 

The PCB is the physical representation of the schematic.  To create a PCB from a schematic, 

click on the „Board‟ button.  A warning window will appear asking you to „Create from 

schematic?‟.  Click Yes. 

 

 
 

Figure 12. Create a PCB 

 

A new window will appear with the Package representation of the components in the schematic 

and a white box.  The white box represents the amount of space available to the user.  For the 

free version of Eagle, users are allowed 4x3 inches of working space.   

 

First, use the Polygon tool and draw a rectangle around the white box.  Polygons are used to 

define layers and planes such as GND planes and power planes.  In the figure below, a GND 

plane is added in order to sink excess heat of components.  Use the Name tool and click on the 

drawn Polygon to rename it. 

 

 
 

Figure 13. Add a Plane 

 

Place the components onto the PCB using the Move tool.  Yellow air wires show components 

that need to be connected to each other or to a common node.  Use the Route tool to connect 

components with a trace.  A trace is a wire, and can be adjusted to meet a certain width, 

thickness, and length.   



When connecting components with traces, there are a few important commands that can be input 

into the command line to effectively layout a board.  Those commands are: 

 

 Grid mm – Switches grid to millimeters 

 Grid inch – Switches grid to inches 

 Grid mil – Switches grid to mills 

 Grid xx – xx refers to the grid unit size 

 Ripup @; - used to remove the ratsnest layer, and to shorten unnecessary airwires 

 

Generally, components can be placed in any type of unit on the grid.  For drawing traces, it is 

highly recommended to switch to mil units because most manufacturers limit a users design in 

mils.   

 

Once the pins of each component are routed to its target location, the user can adjust the board to 

meet his/her own design style.  Depending on the purpose of the board, the user can change the 

shape and size using the Info tool, and can use the Text tool to label necessary components for 

documentation.   

 

1.9 Design Rule Check and Gerber Extraction 

 

Eagle provides a Design Rule Check (DRC) that allows the user to input the fabrication 

limitations of a company that produces PCBs.  Machines can only machine PCBs up to certain 

accuracy, so companies generally state the limits of line thickness and pin separations.  To edit 

the Design Rule Check parameters, click on the DRC button on the bottom of the toolbar.   

 

 
 

Figure 14. Design Rule Check 

 

A new window will appear and allows the user to input the design parameters for the PCB.  

Options that can be edited include copper thickness, wire spacing, minimum drill sizes, and 

isolation sizes between pins.  Be sure to thoroughly read the design limitations of a fabrication 

company and to use the DRC tool to check that the PCB fits within the limits.  If the DRC tool 

returns with inconsistencies after processing, fix the PCB until no errors are returned. 



 
 

Figure 14. Design Rule Check Tool Editor 

 

With the DRC completed, the last step is to generate the files used to fabricate PCBs.  All 

fabrication companies accept Gerber files to print PCBs.  Gerber files are essentially pictures of 

all the layers of the PCB such as the drill layer, copper layer, solder mask layer, silkscreen layer, 

etc.  Eagle provides a Gerber extraction tool which conveniently generates the necessary files for 

fabrication. 

 

To start a Gerber extraction, click on File>CAM Processor.  

 

 
 

Figure 15. CAM Processor 

 

The CAM processor is a scripting tool which takes a build-in extraction processor to generate 

Gerber files.  Different CAM processors can be downloaded to extract necessary files, but Eagles 

default files can do the extraction.  To start an extraction, click on File>Open>Job.  Select the 

CAM script and click „OK’, and then click on „Process Job’.  The files will then be extracted to 

the Control Panel in the project folder. 

 

 



 
 

Figure 16. Gerber Files 

 

Review which files are needed for fabrication (different companies require certain files), and 

copy those files into a new folder.  Zip the folder with the Gerber files and they are ready to be 

sent.   

 

2.0 Tips and Suggestions for Eagle/Fabrication 

 

Fabrication: 

 

There are many companies that fabricate PCBs for large commercial operations and for small 

groups such as students.  Some of the companies that can be used are: 

 

 ITEAD Studio ($)   

 Bay Area Circuits ($$) 

 Advanced Circuits ($$$) 

 

Vendors have different quality levels and turnaround rates.  ITEAD is a company from China, so 

the turnaround rate is long.  The bonus is that the user can get a lot of copies for a cheaper price.  

Other companies such as Bay Area Circuits and Advanced Circuits are U.S. companies so the 

turnaround speed is much faster, but can cost more money.   

 

Soldering/Safety: 

 

Soldering uses high heat and lead to weld components to the PCB.  Most solder is of a 40/60 mix 

of lead and other metals.  When soldering, be sure to have proper ventilation such as a fan or 

fume vacuum on to reduce the amount of contact with dangerous chemicals.  Do not grab the 

soldering iron anywhere below the indicated grip as the heat will cause burns.  Rack the 

soldering iron back into resting position and turn off the machine when not in use.  When 

finished soldering, always remember to tin the solder tip with a coat of solder to prevent the tip 

from burning out.  The user should always wash their hands after soldering, and should clean up 

the soldering area of any rubbish generated during the soldering process.  The rule of thumb with 

working in the lab is to not use machines that the user is unfamiliar with, as safety is priority. 

 

 


